Intune Last Check-in date not updating for Windows device

There was a recent issue where an active device did not report its last check-in date in Intune even though it was actively checking in. No issue with performing sync from access work or school settings, app deployment and OS updates on the device. No errors are being logged in event logs either. Since device was not reporting its Last Check-in time to Intune, it caused an issue with compliance as device is now marked non-compliant in Intune for no check-in over 60 days.

Ultimately, it all came down to one of the windows service that was not running or in disabed state.

DmWapPushService : (“Device Management Wireless Application Protocol (WAP) Push message Routing Service”) , a required service for Intune to properly communicate with clients


Check and enable the DmWapPushService service:

  • Openservices.msc console

  • Under services list, Right-click service name “Device Management Wireless Application Protocol (WAP) Push message Routing Service” and select Properties. In the General tab of properties dialog box, select Automatic (Delayed Start) as startup type.

  • Hit OK
  • Verify that another required service “Microsoft Intune Management Extension” is enabled with startup type as “Automatic (Delayed Start)” as well and in running state.
  • Once the above services are in desired state, Reboot and initiate a check-in with Intune. After 5-10 mins, the last check-in time should be updating with no issues

Microsoft reference: